What’s Vulnerable › Vulnerabilities
CVE-2025-22114: btrfs: don't clobber ret in btrfs_validate_super()
- Severity: medium (CVSS 5.5 v3.1)
- Exploited in the wild: not listed in CISA KEV
- EPSS: 0.2% probability of exploitation in the next 30 days
- Public exploit or detection template: none known
- Published: 2025-04-16 · updated 2026-07-30
Description
In the Linux kernel, the following vulnerability has been resolved: btrfs: don't clobber ret in btrfs_validate_super() Commit 2a9bb78cfd36 ("btrfs: validate system chunk array at btrfs_validate_super()") introduces a call to validate_sys_chunk_array() in btrfs_validate_super(), which clobbers the value of ret set earlier. This has the effect of negating the validity checks done earlier, making it so btrfs could potentially try to mount invalid filesystems.
Affected products
- Linux kernel: from 6.14 before 6.14.2 — fixed in 6.14.2
How to fix
Upgrade to a fixed version: Linux kernel 6.14.2. Check the vendor advisory for mitigations.
References
- https://git.kernel.org/stable/c/9db9c7dd5b4e1d3205137a094805980082c37716
- https://git.kernel.org/stable/c/ef6800a2015e706e9852a5ec15263fec9990d012
Get alerted when CVE-2025-22114 or the next vulnerability affects your stack