What’s Vulnerable › Vulnerabilities
CVE-2025-22130: Soft Serve allows path traversal attacks
- Severity: high (CVSS 8.8 v3.1)
- Exploited in the wild: not listed in CISA KEV
- EPSS: 0.7% probability of exploitation in the next 30 days
- Public exploit or detection template: none known
- Published: 2025-01-08 · updated 2026-06-17
- Weakness: CWE-22
Description
Soft Serve is a self-hostable Git server for the command line. Prior to 0.8.2 , a path traversal attack allows existing non-admin users to access and take over other user's repositories. A malicious user then can modify, delete, and arbitrarily repositories as if they were an admin user without explicitly giving them permissions. This is patched in v0.8.2.
Affected products
- charmbracelet soft-serve: before 0.8.2 — fixed in 0.8.2
How to fix
Upgrade to a fixed version: charmbracelet soft-serve 0.8.2. Check the vendor advisory for mitigations.
References
- https://github.com/charmbracelet/soft-serve/commit/a8d1bf3f9349c138383b65079b7b8ad97fff78f4
- https://github.com/charmbracelet/soft-serve/releases/tag/v0.8.2
- https://github.com/charmbracelet/soft-serve/security/advisories/GHSA-j4jw-m6xr-fv6c
Get alerted when CVE-2025-22130 or the next vulnerability affects your stack