What’s Vulnerable › Vulnerabilities
CVE-2025-22131: Cross-Site Scripting (XSS) vulnerability in generateNavigation() function
- Severity: medium (CVSS 6.1 v3.1)
- Exploited in the wild: not listed in CISA KEV
- EPSS: 0.4% probability of exploitation in the next 30 days
- Public exploit or detection template: yes
- Published: 2025-01-20 · updated 2026-06-17
- Weakness: CWE-79
Description
PhpSpreadsheet is a PHP library for reading and writing spreadsheet files. Cross-Site Scripting (XSS) vulnerability in the code which translates the XLSX file into a HTML representation and displays it in the response.
Affected products
- PHPOffice PhpSpreadsheet: before 1.29.8; from 2.0.0 before 2.1.7; from 2.2.0 before 2.3.6; from 3.0.0 before 3.8.0 — fixed in 1.29.8, 2.1.7, 2.3.6, 3.8.0
How to fix
Upgrade to a fixed version: PHPOffice PhpSpreadsheet 1.29.8, 2.1.7, 2.3.6, 3.8.0. Check the vendor advisory for mitigations.
References
- https://github.com/PHPOffice/PhpSpreadsheet/commit/4088381ccfaf241d7d42c333de0dc8c98e338743
- https://github.com/PHPOffice/PhpSpreadsheet/security/advisories/GHSA-79xx-vf93-p7cx
Get alerted when CVE-2025-22131 or the next vulnerability affects your stack