What’s Vulnerable › Vulnerabilities
CVE-2025-22146: Improper authentication on SAML SSO process allows user impersonation in sentry
- Severity: critical (CVSS 9.1 v3.1)
- Exploited in the wild: not listed in CISA KEV
- EPSS: 0.6% probability of exploitation in the next 30 days
- Public exploit or detection template: none known
- Published: 2025-01-15 · updated 2026-06-17
- Weakness: CWE-287
Description
Sentry is a developer-first error tracking and performance monitoring tool. A critical vulnerability was discovered in the SAML SSO implementation of Sentry. It was reported to us via our private bug bounty program. The vulnerability allows an attacker to take over any user account by using a malicious SAML Identity Provider and another organization on the same Sentry instance. The victim email address must be known in order to exploit this vulnerability. The Sentry SaaS fix was deployed on Jan 14, 2025. For self hosted users; if only a single organization is allowed `(SENTRY_SINGLE_ORGANIZATION = True)`, then no action is needed. Otherwise, users should upgrade to version 25.1.0 or higher. There are no known workarounds for this vulnerability.
Affected products
- getsentry sentry: from 21.12.0, < 25.1.0
References
- https://github.com/getsentry/sentry/pull/83407
- https://github.com/getsentry/sentry/security/advisories/GHSA-7pq6-v88g-wf3w
Get alerted when CVE-2025-22146 or the next vulnerability affects your stack