What’s Vulnerable › Vulnerabilities

CVE-2025-22150: Undici Uses Insufficiently Random Values

Description

Undici is an HTTP/1.1 client. Starting in version 4.5.0 and prior to versions 5.28.5, 6.21.1, and 7.2.3, undici uses `Math.random()` to choose the boundary for a multipart/form-data request. It is known that the output of `Math.random()` can be predicted if several of its generated values are known. If there is a mechanism in an app that sends multipart requests to an attacker-controlled website, they can use this to leak the necessary values. Therefore, an attacker can tamper with the requests going to the backend APIs if certain conditions are met. This is fixed in versions 5.28.5, 6.21.1, and 7.2.3. As a workaround, do not issue multipart requests to attacker controlled servers.

Affected products

How to fix

Upgrade to a fixed version: Npm Undici 5.28.5, 6.21.1, 7.2.3. Check the vendor advisory for mitigations.

References

Get alerted when CVE-2025-22150 or the next vulnerability affects your stack