What’s Vulnerable › Vulnerabilities
CVE-2025-22157
- Severity: high (CVSS 8.8 v3.1)
- Exploited in the wild: not listed in CISA KEV
- EPSS: 0.7% probability of exploitation in the next 30 days
- Public exploit or detection template: none known
- Published: 2025-05-20 · updated 2026-06-17
- Weakness: CWE-284
Description
This High severity PrivEsc (Privilege Escalation) vulnerability was introduced in versions: 9.12.0, 10.3.0, 10.4.0, and 10.5.0 of Jira Core Data Center and Server 5.12.0, 10.3.0, 10.4.0, and 10.5.0 of Jira Service Management Data Center and Server This PrivEsc (Privilege Escalation) vulnerability, with a CVSS Score of 7.2, allows an attacker to perform actions as a higher-privileged user. Atlassian recommends that Jira Core Data Center and Server and Jira Service Management Data Center and Server customers upgrade to latest version, if you are unable to do so, upgrade your instance to one of the specified supported fixed versions: Jira Core Data Center and Server 9.12: Upgrade to a release greater than or equal to 9.12.20 Jira Service Management Data Center and Server 5.12: Upgrade to a release greater than or equal to 5.12.20 Jira Core Data Center 10.3: Upgrade to a release greater than or equal to 10.3.5 Jira Service Management Data Center 10.3: Upgrade to a release greater than or equal to 10.3.5 Jira Core Data Center 10.4: Upgrade to a release greater than or equal to 10.6.0 Jira Service Management Data Center 10.4: Upgrade to a release greater than or equal to 10.6.0 Jira Core Data Center 10.5: Upgrade to a release greater than or equal to 10.5.1 Jira Service Management Data Center 10.5: Upgrade to a release greater than or equal to 10.5.1 See the release notes. You can download the latest version of Jira Core Data Center and Jira Service Management Data Center from the download center. This vulnerability was reported via our Atlassian (Internal) program.
Affected products
- Atlassian Jira: from 5.12.0 before 5.12.20; from 9.12.0 before 9.12.20; from 10.3.0 before 10.3.5; from 10.4.0 before 10.5.1 — fixed in 10.3.5, 10.5.1, 5.12.20, 9.12.20
- Atlassian Jira: from 9.12.0 before 9.12.20; from 10.3.0 before 10.3.5; from 10.4.0 before 10.5.1 — fixed in 10.3.5, 10.5.1, 9.12.20
How to fix
Upgrade to a fixed version: Atlassian Jira 10.3.5, 10.5.1, 5.12.20, 9.12.20; Atlassian Jira 10.3.5, 10.5.1, 9.12.20. Check the vendor advisory for mitigations.
References
- https://confluence.atlassian.com/pages/viewpage.action?pageId=1561365992
- https://jira.atlassian.com/browse/JRASERVER-78766
- https://jira.atlassian.com/browse/JSDSERVER-16206
Get alerted when CVE-2025-22157 or the next vulnerability affects your stack