What’s Vulnerable › Vulnerabilities
CVE-2025-22166
- Severity: high (CVSS 7.5 v3.1)
- Exploited in the wild: not listed in CISA KEV
- EPSS: 0.5% probability of exploitation in the next 30 days
- Public exploit or detection template: none known
- Published: 2025-10-21 · updated 2026-10-08
- Weakness: CWE-405
Description
This High severity DoS (Denial of Service) vulnerability was introduced in version 2.0 of Confluence Data Center. This DoS (Denial of Service) vulnerability, with a CVSS Score of 8.3, allows an attacker to cause a resource to be unavailable for its intended users by temporarily or indefinitely disrupting services of a host connected to a network. Atlassian recommends that Confluence Data Center customers upgrade to latest version, if you are unable to do so, upgrade your instance to one of the specified supported fixed versions: Confluence Data Center and Server 8.5: Upgrade to a release greater than or equal to 8.5.25 Confluence Data Center and Server 9.2: Upgrade to a release greater than or equal to 9.2.7 Confluence Data Center and Server 10.0: Upgrade to a release greater than or equal to 10.0.2 See the release notes ([https://confluence.atlassian.com/doc/confluence-release-notes-327.html]). You can download the latest version of Confluence Data Center from the download center ([https://www.atlassian.com/software/confluence/download-archives]). This vulnerability was reported via our Atlassian (Internal) program.
Affected products
- Atlassian Confluence Data Center: from 8.5.0 before 8.5.25; from 9.2.0 before 9.2.7; from 10.0.0 before 10.0.2 — fixed in 10.0.2, 8.5.25, 9.2.7
- Atlassian Confluence Data Center: from 8.5.0 before 8.5.25; from 9.2.0 before 9.2.7; from 10.0.0 before 10.0.2 — fixed in 10.0.2, 8.5.25, 9.2.7
How to fix
Upgrade to a fixed version: Atlassian Confluence Data Center 10.0.2, 8.5.25, 9.2.7; Atlassian Confluence Data Center 10.0.2, 8.5.25, 9.2.7. Check the vendor advisory for mitigations.
References
- https://confluence.atlassian.com/pages/viewpage.action?pageId=1652920034
- https://jira.atlassian.com/browse/CONFSERVER-100907
Get alerted when CVE-2025-22166 or the next vulnerability affects your stack