What’s Vulnerable › Vulnerabilities
CVE-2025-22216: CVE-2025-22216 UAA Missing Zone Validation
- Severity: medium (CVSS 5.4 v3.1)
- Exploited in the wild: not listed in CISA KEV
- EPSS: 0.2% probability of exploitation in the next 30 days
- Public exploit or detection template: none known
- Published: 2025-01-31 · updated 2026-06-17
- Weakness: CWE-384
Description
A UAA configured with multiple identity zones, does not properly validate session information across those zones. A User authenticated against a corporate IDP can re-use their jsessionid to access other zones.
Affected products
- Cloud Foundry UAA: from 77.20.X before 77.20.2; from 77.2X.0 before 77.25.0 — fixed in 77.20.2, 77.25.0
How to fix
Upgrade to a fixed version: Cloud Foundry UAA 77.20.2, 77.25.0. Check the vendor advisory for mitigations.
References
Get alerted when CVE-2025-22216 or the next vulnerability affects your stack