What’s Vulnerable › Vulnerabilities
CVE-2025-22219: VMware Aria Operations for Logs stored cross-site scripting vulnerability (CVE-2025-22219)
- Severity: critical (CVSS 9.0 v3.1)
- Exploited in the wild: not listed in CISA KEV
- EPSS: 0.7% probability of exploitation in the next 30 days
- Public exploit or detection template: none known
- Published: 2025-01-30 · updated 2026-06-17
- Weakness: CWE-79
Description
VMware Aria Operations for Logs contains a stored cross-site scripting vulnerability. A malicious actor with non-administrative privileges may be able to inject a malicious script that (can perform stored cross-site scripting) may lead to arbitrary operations as admin user.
Affected products
- VMware Aria Operations for Logs: from 8.0 before 8.18.3 — fixed in 8.18.3
- VMware Cloud Foundation: from 4.0 through 5.2
- VMware Aria Operations for Logs: from 8.x before 8.18.3 — fixed in 8.18.3
How to fix
Upgrade to a fixed version: VMware Aria Operations for Logs 8.18.3; VMware Aria Operations for Logs 8.18.3. Check the vendor advisory for mitigations.
References
Get alerted when CVE-2025-22219 or the next vulnerability affects your stack