What’s Vulnerable › Vulnerabilities
CVE-2025-22243
- Severity: high (CVSS 7.5 v3.1)
- Exploited in the wild: not listed in CISA KEV
- EPSS: 0.3% probability of exploitation in the next 30 days
- Public exploit or detection template: none known
- Published: 2025-06-04 · updated 2026-06-17
- Weakness: CWE-79
Description
VMware NSX Manager UI is vulnerable to a stored Cross-Site Scripting (XSS) attack due to improper input validation.
Affected products
- Broadcom Vmware Nsx: from 3.2 before 4.1.2.6; from 4.2.1 before 4.2.1.4; 4.2.2 — fixed in 4.1.2.6, 4.2.1.4
- VMware Cloud Foundation: from 4.5 through 5.2.1.2
- VMware Telco Cloud Infrastructure: from 2.2 through 3.0
- VMware Telco Cloud Platform: from 3.0 through 5.0
- VMware NSX: VMware NSX 4.0.x, VMware NSX 4.1.x, VMware NSX 4.2.x
How to fix
Upgrade to a fixed version: Broadcom Vmware Nsx 4.1.2.6, 4.2.1.4. Check the vendor advisory for mitigations.
References
Get alerted when CVE-2025-22243 or the next vulnerability affects your stack