What’s Vulnerable › Vulnerabilities
CVE-2025-22249: VMSA-2025-0008: VMware Aria automation updates address a DOM based Cross-site scripting vulnerability (CVE-2025-22249)
- Severity: high (CVSS 8.2 v3.1)
- Exploited in the wild: not listed in CISA KEV
- EPSS: 0.4% probability of exploitation in the next 30 days
- Public exploit or detection template: none known
- Published: 2025-05-13 · updated 2026-06-17
- Weakness: CWE-79
Description
VMware Aria automation contains a DOM based Cross-Site Scripting (XSS) vulnerability. A malicious actor may exploit this issue to steal the access token of a logged in user of VMware Aria automation appliance by tricking the user into clicking a malicious crafted payload URL.
Affected products
- VMware Aria Automation: 8.18.0, 8.18.1, 8.18.1-patch1
- VMware Cloud Foundation: from 4.0 through 5.2.1
- VMware Telco Cloud Platform: from 5.0 through 5.0.1
- VMware Aria Automation: from 8.18.x before 8.18.1 patch2 — fixed in 8.18.1 patch2
- VMware Cloud Foundation: from 5.x before 8.18.1 patch 2; from 4.x before 8.18.1 patch 2 — fixed in 8.18.1 patch 2
- VMware Telco Cloud Platform: from 5.x before 8.18.1 patch 2 — fixed in 8.18.1 patch 2
How to fix
Upgrade to a fixed version: VMware Aria Automation 8.18.1 patch2; VMware Cloud Foundation 8.18.1 patch 2; VMware Telco Cloud Platform 8.18.1 patch 2. Check the vendor advisory for mitigations.
References
Get alerted when CVE-2025-22249 or the next vulnerability affects your stack