What’s Vulnerable › Vulnerabilities
CVE-2025-2225: Responsive Addons for Elementor – Free Elementor Addons Plugin and Elementor Templates <= 1.6.9 - Authenticated (Contributor+) Stored Cross-Site Scripting via 'rael_title_tag'
- Severity: medium (CVSS 5.4 v3.1)
- Exploited in the wild: not listed in CISA KEV
- EPSS: 0.3% probability of exploitation in the next 30 days
- Public exploit or detection template: none known
- Published: 2025-04-15 · updated 2026-06-17
- Weakness: CWE-79
Description
The Responsive Addons for Elementor – Free Elementor Addons Plugin and Elementor Templates plugin for WordPress is vulnerable to Stored Cross-Site Scripting via the ‘rael_title_tag' parameter in all versions up to, and including, 1.6.9 due to insufficient input sanitization and output escaping. This makes it possible for authenticated attackers, with Contributor-level access and above, to inject arbitrary web scripts in pages that will execute whenever a user accesses an injected page. The vulnerability was partially patched in version 1.6.9.
Affected products
- cyberchimps Responsive Addons for Elementor – Free Elementor Addons, Kits and Elementor Templates: before 1.6.9.1 — fixed in 1.6.9.1
How to fix
Upgrade to a fixed version: cyberchimps Responsive Addons for Elementor – Free Elementor Addons, Kits and Elementor Templates 1.6.9.1. Check the vendor advisory for mitigations.
References
- https://plugins.trac.wordpress.org/browser/responsive-addons-for-elementor/trunk/includes/widgets-manager/widgets/class-responsive-addons-for-elementor-icon-box.php#L2499
- https://plugins.trac.wordpress.org/changeset/3261241/
- https://plugins.trac.wordpress.org/changeset/3263280/
- https://www.wordfence.com/threat-intel/vulnerabilities/id/f5ace7fb-530e-4a69-bbf7-e2c66491dd75?source=cve
Get alerted when CVE-2025-2225 or the next vulnerability affects your stack