What’s Vulnerable › Vulnerabilities

CVE-2025-22251

Description

An improper restriction of communication channel to intended endpoints vulnerability [CWE-923] in FortiOS 7.6.0, 7.4.0 through 7.4.5, 7.2 all versions, 7.0 all versions, 6.4 all versions may allow an unauthenticated attacker to inject unauthorized sessions via crafted FGSP session synchronization packets.

Affected products

How to fix

Upgrade to a fixed version: Fortinet FortiOS (FortiGate) 7.4.6. Check the vendor advisory for mitigations.

References

Get alerted when CVE-2025-22251 or the next vulnerability affects your stack