What’s Vulnerable › Vulnerabilities

CVE-2025-22254

Description

An Improper Privilege Management vulnerability [CWE-269] vulnerability in Fortinet FortiOS 7.6.0 through 7.6.1, FortiOS 7.4.0 through 7.4.6, FortiOS 7.2.0 through 7.2.10, FortiOS 7.0.0 through 7.0.16, FortiOS 6.4.0 through 6.4.15, FortiProxy 7.6.0 through 7.6.1, FortiProxy 7.4.0 through 7.4.7, FortiWeb 7.6.0 through 7.6.1, FortiWeb 7.4.0 through 7.4.6 allows an authenticated attacker with at least read-only admin permissions to gain super-admin privileges via crafted requests to Node.js websocket module.

Affected products

How to fix

Upgrade to a fixed version: Fortinet FortiOS (FortiGate) 6.4.16, 7.0.17, 7.2.11, 7.4.7; Fortinet FortiProxy 7.4.8, 7.6.2; Fortinet FortiWeb 7.4.7, 7.6.2. Check the vendor advisory for mitigations.

References

Get alerted when CVE-2025-22254 or the next vulnerability affects your stack