What’s Vulnerable › Vulnerabilities

CVE-2025-22258

Description

A heap-based buffer overflow in Fortinet FortiSRA 1.5.0, 1.4.0 through 1.4.2, FortiPAM 1.5.0, 1.4.0 through 1.4.2, 1.3.0 through 1.3.1, 1.2.0, 1.1.0 through 1.1.2, 1.0.0 through 1.0.3, FortiProxy 7.6.0 through 7.6.1, 7.4.0 through 7.4.7, FortiOS 7.6.0 through 7.6.2, 7.4.0 through 7.4.6, 7.2.0 through 7.2.10, 7.0.2 through 7.0.16, FortiSwitchManager 7.2.1 through 7.2.5 allows attackers to escalate their privilege via specially crafted http requests.

Affected products

How to fix

Upgrade to a fixed version: Fortinet FortiOS (FortiGate) 7.0.17, 7.2.11, 7.4.7, 7.6.3; Fortinet FortiPAM 1.4.3; Fortinet FortiProxy 7.4.8, 7.6.2; Fortinet FortiSRA 1.4.3; Fortinet FortiSwitchManager 7.2.6. Check the vendor advisory for mitigations.

References

Get alerted when CVE-2025-22258 or the next vulnerability affects your stack