What’s Vulnerable › Vulnerabilities
CVE-2025-22275
- Severity: critical (CVSS 9.3 v3.1)
- Exploited in the wild: not listed in CISA KEV
- EPSS: 0.5% probability of exploitation in the next 30 days
- Public exploit or detection template: none known
- Published: 2025-01-03 · updated 2026-06-17
- Weakness: CWE-532
Description
iTerm2 3.5.6 through 3.5.10 before 3.5.11 sometimes allows remote attackers to obtain sensitive information from terminal commands by reading the /tmp/framer.txt file. This can occur for certain it2ssh and SSH Integration configurations, during remote logins to hosts that have a common Python installation.
Affected products
- iTerm2: from 3.5.6 before 3.5.11 — fixed in 3.5.11
How to fix
Upgrade to a fixed version: iTerm2 3.5.11. Check the vendor advisory for mitigations.
References
- https://gitlab.com/gnachman/iterm2/-/wikis/SSH-Integration-Information-Leak
- https://iterm2.com/downloads/stable/iTerm2-3_5_11.changelog
- https://news.ycombinator.com/item?id=42579472
Get alerted when CVE-2025-22275 or the next vulnerability affects your stack