What’s Vulnerable › Vulnerabilities
CVE-2025-2228: Responsive Addons for Elementor – Free Elementor Addons Plugin and Elementor Templates <= 1.6.8 - Authenticated (Contributor+) Sensitive Information Exposure
- Severity: medium (CVSS 5.7 v3.1)
- Exploited in the wild: not listed in CISA KEV
- EPSS: 0.4% probability of exploitation in the next 30 days
- Public exploit or detection template: none known
- Published: 2025-03-26 · updated 2026-06-17
- Weakness: CWE-200
Description
The Responsive Addons for Elementor – Free Elementor Addons Plugin and Elementor Templates plugin for WordPress is vulnerable to Sensitive Information Exposure in all versions up to, and including, 1.6.8 the 'register_user' function. This makes it possible for authenticated attackers, with Contributor-level access and above, to extract sensitive data including usernames and passwords of any users who register via the Edit Login | Registration Form widget, as long as that user opens the email notification for successful registration.
Affected products
- cyberchimps Responsive Addons for Elementor – Free Elementor Addons, Kits and Elementor Templates: before 1.6.9 — fixed in 1.6.9
How to fix
Upgrade to a fixed version: cyberchimps Responsive Addons for Elementor – Free Elementor Addons, Kits and Elementor Templates 1.6.9. Check the vendor advisory for mitigations.
References
- https://plugins.trac.wordpress.org/browser/responsive-addons-for-elementor/trunk/includes/modules-manager/login-register/class-login-register.php#L369
- https://plugins.trac.wordpress.org/changeset/3261241/
- https://www.wordfence.com/threat-intel/vulnerabilities/id/659ef2e8-589c-4901-88ce-1d674c056ece?source=cve
Get alerted when CVE-2025-2228 or the next vulnerability affects your stack