What’s Vulnerable › Vulnerabilities
CVE-2025-22389
- Severity: high (CVSS 8.0 v3.1)
- Exploited in the wild: not listed in CISA KEV
- EPSS: 0.5% probability of exploitation in the next 30 days
- Public exploit or detection template: none known
- Published: 2025-01-04 · updated 2026-06-17
- Weakness: CWE-434
Description
An issue was discovered in Optimizely EPiServer.CMS.Core before 12.32.0. A medium-severity vulnerability exists in the CMS, where the application does not properly validate uploaded files. This allows the upload of potentially malicious file types, including .docm .html. When accessed by application users, these files can be used to execute malicious actions or compromise users' systems.
Affected products
- Optimizely Cms: before 12.32.0 — fixed in 12.32.0
How to fix
Upgrade to a fixed version: Optimizely Cms 12.32.0. Check the vendor advisory for mitigations.
References
Get alerted when CVE-2025-22389 or the next vulnerability affects your stack