What’s Vulnerable › Vulnerabilities
CVE-2025-2242: Incorrect Authorization in GitLab
- Severity: high (CVSS 8.8 v3.1)
- Exploited in the wild: not listed in CISA KEV
- EPSS: 0.4% probability of exploitation in the next 30 days
- Public exploit or detection template: none known
- Published: 2025-03-27 · updated 2026-06-17
- Weakness: CWE-863
Description
An improper access control vulnerability in GitLab CE/EE affecting all versions from 17.4 prior to 17.8.6, 17.9 prior to 17.9.3, and 17.10 prior to 17.10.1 allows a user who was an instance admin before but has since been downgraded to a regular user to continue to maintain elevated privileges to groups and projects.
Affected products
- GitLab: from 17.4.0 before 17.8.6; from 17.9.0 before 17.9.3; 17.10.0 — fixed in 17.8.6, 17.9.3
How to fix
Upgrade to a fixed version: GitLab 17.8.6, 17.9.3. Check the vendor advisory for mitigations.
References
Get alerted when CVE-2025-2242 or the next vulnerability affects your stack