What’s Vulnerable › Vulnerabilities
CVE-2025-22483: License Center
- Severity: medium (CVSS 4.8 v3.1)
- Exploited in the wild: not listed in CISA KEV
- EPSS: 0.2% probability of exploitation in the next 30 days
- Public exploit or detection template: none known
- Published: 2025-08-29 · updated 2026-10-18
- Weakness: CWE-79
Description
A cross-site scripting (XSS) vulnerability has been reported to affect several QNAP operating system versions. If a remote attacker gains an administrator account, they can then exploit the vulnerability to bypass security mechanisms or read application data. We have already fixed the vulnerability in the following versions: License Center 1.8.51 and later License Center 1.9.51 and later
Affected products
- QNAP Systems Inc. License Center: from 1.8.17 before 1.8.51; from 1.9.36 before 1.9.51 — fixed in 1.8.51, 1.9.51
How to fix
Upgrade to a fixed version: QNAP Systems Inc. License Center 1.8.51, 1.9.51. Check the vendor advisory for mitigations.
References
Get alerted when CVE-2025-22483 or the next vulnerability affects your stack