What’s Vulnerable › Vulnerabilities

CVE-2025-2254: Improper Neutralization of Input During Web Page Generation ('Cross-site Scripting') in GitLab

Description

An issue has been discovered in GitLab CE/EE affecting all versions from 17.9 before 17.10.8, 17.11 before 17.11.4, and 18.0 before 18.0.2. Improper output encoding in the snipper viewer functionality lead to Cross-Site scripting attacks.

Affected products

How to fix

Upgrade to a fixed version: GitLab 17.10.8, 17.11.4, 18.0.2. Check the vendor advisory for mitigations.

References

Get alerted when CVE-2025-2254 or the next vulnerability affects your stack