What’s Vulnerable › Vulnerabilities

CVE-2025-2256: Improper Validation of Specified Quantity in Input in GitLab

Description

An issue has been discovered in GitLab CE/EE affecting all versions from 7.12 before 18.1.6, 18.2 before 18.2.6, and 18.3 before 18.3.2 that could have allowed unauthorized users to render the GitLab instance unresponsive to legitimate users by sending multiple concurrent large SAML responses.

Affected products

How to fix

Upgrade to a fixed version: GitLab 18.1.6, 18.2.6, 18.3.2. Check the vendor advisory for mitigations.

References

Get alerted when CVE-2025-2256 or the next vulnerability affects your stack