What’s Vulnerable › Vulnerabilities
CVE-2025-2257: Total Upkeep – WordPress Backup Plugin plus Restore & Migrate by BoldGrid <= 1.16.10 - Authenticated (Admin+) Command Injection
- Severity: high (CVSS 7.2 v3.1)
- Exploited in the wild: not listed in CISA KEV
- EPSS: 0.9% probability of exploitation in the next 30 days
- Public exploit or detection template: none known
- Published: 2025-03-26 · updated 2026-06-17
- Weakness: CWE-78
Description
The Total Upkeep – WordPress Backup Plugin plus Restore & Migrate by BoldGrid plugin for WordPress is vulnerable to Remote Code Execution in all versions up to, and including, 1.16.10 via the compression_level setting. This is due to the plugin using the compression_level setting in proc_open() without any validation. This makes it possible for authenticated attackers, with administrator-level access and above, to execute code on the server.
Affected products
- boldgrid Total Upkeep – WordPress Backup Plugin plus Restore & Migrate by BoldGrid: before 1.17.0 — fixed in 1.17.0
How to fix
Upgrade to a fixed version: boldgrid Total Upkeep – WordPress Backup Plugin plus Restore & Migrate by BoldGrid 1.17.0. Check the vendor advisory for mitigations.
References
- https://github.com/BoldGrid/boldgrid-backup/pull/622/files
- https://plugins.svn.wordpress.org/boldgrid-backup/tags/1.16.7/admin/compressor/class-boldgrid-backup-admin-compressor-system-zip.php
- https://plugins.trac.wordpress.org/changeset?sfp_email=&sfph_mail=&reponame=&old=3257988%40boldgrid-backup&new=3257988%40boldgrid-backup&sfp_email=&sfph_mail=#file9
- https://www.wordfence.com/threat-intel/vulnerabilities/id/1ec3cc3e-c11b-43b6-9dd0-caa5ccfb90c8?source=cve
Get alerted when CVE-2025-2257 or the next vulnerability affects your stack