What’s Vulnerable › Vulnerabilities
CVE-2025-2260: Eclipse ThreadX NetX Duo HTTP component server denial of service
- Severity: high (CVSS 7.5 v3.1)
- Exploited in the wild: not listed in CISA KEV
- EPSS: 1.0% probability of exploitation in the next 30 days
- Public exploit or detection template: none known
- Published: 2025-04-06 · updated 2026-06-17
- Weakness: CWE-459
Description
In NetX HTTP server functionality of Eclipse ThreadX NetX Duo before version 6.4.3, an attacker can cause a denial of service by specially crafted packets. The core issue is missing closing of a file in case of an error condition, resulting in the 404 error for each further file request. Users can work-around the issue by disabling the PUT request support. This issue follows an incomplete fix of CVE-2025-0726.
Affected products
- Eclipse Foundation NetX Duo: before 6.4.3 — fixed in 6.4.3
How to fix
Upgrade to a fixed version: Eclipse Foundation NetX Duo 6.4.3. Check the vendor advisory for mitigations.
References
- https://github.com/eclipse-threadx/netxduo/commit/fb3195bbb6d0d6fe71a7a19585c008623c217f9e
- https://github.com/eclipse-threadx/netxduo/security/advisories/GHSA-f42f-6fvv-xqx3
- https://www.talosintelligence.com/vulnerability_reports/TALOS-2024-2098
Get alerted when CVE-2025-2260 or the next vulnerability affects your stack