What’s Vulnerable › Vulnerabilities
CVE-2025-22601: Client Side Path Traversal using activate account route in Discourse
- Severity: low (CVSS 3.1 v3.1)
- Exploited in the wild: not listed in CISA KEV
- EPSS: 0.4% probability of exploitation in the next 30 days
- Public exploit or detection template: none known
- Published: 2025-02-04 · updated 2026-06-17
- Weakness: CWE-22
Description
Discourse is an open source platform for community discussion. In affected versions an attacker can trick a target user to make changes to their own username via carefully crafted link using the `activate-account` route. This problem has been patched in the latest version of Discourse. Users are advised to upgrade. There are no known workarounds for this vulnerability.
Affected products
- discourse: before 3.4.0; 3.4.0-beta1, 3.4.0-beta2, 3.4.0-beta3 — fixed in 3.4.0
How to fix
Upgrade to a fixed version: discourse 3.4.0. Check the vendor advisory for mitigations.
References
Get alerted when CVE-2025-22601 or the next vulnerability affects your stack