What’s Vulnerable › Vulnerabilities
CVE-2025-22697: WordPress Responsive Blocks plugin <= 1.9.9 - Cross Site Scripting (XSS) vulnerability
- Severity: medium (CVSS 5.4 v3.1)
- Exploited in the wild: not listed in CISA KEV
- EPSS: 0.2% probability of exploitation in the next 30 days
- Public exploit or detection template: none known
- Published: 2025-02-04 · updated 2026-06-17
- Weakness: CWE-79
Description
Improper Neutralization of Input During Web Page Generation ('Cross-site Scripting') vulnerability in CyberChimps Responsive Blocks responsive-block-editor-addons allows Reflected XSS.This issue affects Responsive Blocks: from n/a through <= 1.9.9.
Affected products
- CyberChimps Responsive Blocks: before 2.0.0 — fixed in 2.0.0
How to fix
Upgrade to a fixed version: CyberChimps Responsive Blocks 2.0.0. Check the vendor advisory for mitigations.
References
Get alerted when CVE-2025-22697 or the next vulnerability affects your stack