What’s Vulnerable › Vulnerabilities
CVE-2025-22738: WordPress WP ULike plugin <= 4.7.6 - Cross Site Scripting (XSS) vulnerability
- Severity: medium (CVSS 4.8 v3.1)
- Exploited in the wild: not listed in CISA KEV
- EPSS: 0.3% probability of exploitation in the next 30 days
- Public exploit or detection template: none known
- Published: 2025-01-15 · updated 2026-06-17
- Weakness: CWE-79
Description
Improper Neutralization of Input During Web Page Generation ('Cross-site Scripting') vulnerability in Alimir WP ULike wp-ulike allows Stored XSS.This issue affects WP ULike: from n/a through <= 4.7.6.
Affected products
- alimir WP ULike – Like & Dislike Buttons for Engagement and Feedback: before 4.7.7 — fixed in 4.7.7
How to fix
Upgrade to a fixed version: alimir WP ULike – Like & Dislike Buttons for Engagement and Feedback 4.7.7. Check the vendor advisory for mitigations.
References
Get alerted when CVE-2025-22738 or the next vulnerability affects your stack