What’s Vulnerable › Vulnerabilities
CVE-2025-22759: WordPress Post and Page Builder by BoldGrid – Visual Drag and Drop Editor plugin <= 1.27.5 - Cross Site Scripting (XSS) vulnerability
- Severity: medium (CVSS 5.4 v3.1)
- Exploited in the wild: not listed in CISA KEV
- EPSS: 0.3% probability of exploitation in the next 30 days
- Public exploit or detection template: none known
- Published: 2025-01-15 · updated 2026-06-17
- Weakness: CWE-79
Description
Improper Neutralization of Input During Web Page Generation ('Cross-site Scripting') vulnerability in BoldGrid Post and Page Builder by BoldGrid post-and-page-builder allows Stored XSS.This issue affects Post and Page Builder by BoldGrid: from n/a through <= 1.27.5.
Affected products
- BoldGrid Post and Page Builder by BoldGrid: before 1.27.6 — fixed in 1.27.6
How to fix
Upgrade to a fixed version: BoldGrid Post and Page Builder by BoldGrid 1.27.6. Check the vendor advisory for mitigations.
References
Get alerted when CVE-2025-22759 or the next vulnerability affects your stack