What’s Vulnerable › Vulnerabilities
CVE-2025-2277
- Severity: high (CVSS 7.5 v3.1)
- Exploited in the wild: not listed in CISA KEV
- EPSS: 0.6% probability of exploitation in the next 30 days
- Public exploit or detection template: none known
- Published: 2025-03-13 · updated 2026-06-17
- Weakness: CWE-200
Description
Exposure of password in web-based SSH authentication component in Devolutions Server 2024.3.13 and earlier allows a user to unadvertently leak his SSH password due to missing password masking.
Affected products
- Devolutions Server: before 2025.1.3.0 — fixed in 2025.1.3.0
How to fix
Upgrade to a fixed version: Devolutions Server 2025.1.3.0. Check the vendor advisory for mitigations.
References
Get alerted when CVE-2025-2277 or the next vulnerability affects your stack