What’s Vulnerable › Vulnerabilities
CVE-2025-22787: WordPress Button Block plugin <= 1.1.5 - Broken Access Control vulnerability
- Severity: high (CVSS 8.8 v3.1)
- Exploited in the wild: not listed in CISA KEV
- EPSS: 0.3% probability of exploitation in the next 30 days
- Public exploit or detection template: none known
- Published: 2025-01-15 · updated 2026-06-17
- Weakness: CWE-862
Description
Missing Authorization vulnerability in bPlugins Button Block button-block allows Accessing Functionality Not Properly Constrained by ACLs.This issue affects Button Block: from n/a through <= 1.1.5.
Affected products
- bPlugins Button Block: before 1.1.6 — fixed in 1.1.6
How to fix
Upgrade to a fixed version: bPlugins Button Block 1.1.6. Check the vendor advisory for mitigations.
References
Get alerted when CVE-2025-22787 or the next vulnerability affects your stack