What’s Vulnerable › Vulnerabilities
CVE-2025-22806: WordPress Black Widgets For Elementor plugin <= 1.3.8 - Cross Site Scripting (XSS) vulnerability
- Severity: medium (CVSS 5.4 v3.1)
- Exploited in the wild: not listed in CISA KEV
- EPSS: 0.2% probability of exploitation in the next 30 days
- Public exploit or detection template: none known
- Published: 2025-01-09 · updated 2026-06-17
- Weakness: CWE-79
Description
Improper Neutralization of Input During Web Page Generation ('Cross-site Scripting') vulnerability in Modernaweb Studio Black Widgets For Elementor black-widgets allows DOM-Based XSS.This issue affects Black Widgets For Elementor: from n/a through <= 1.3.8.
Affected products
- Modernaweb Studio Black Widgets For Elementor: before 1.3.9 — fixed in 1.3.9
How to fix
Upgrade to a fixed version: Modernaweb Studio Black Widgets For Elementor 1.3.9. Check the vendor advisory for mitigations.
References
Get alerted when CVE-2025-22806 or the next vulnerability affects your stack