What’s Vulnerable › Vulnerabilities
CVE-2025-22815: WordPress Button Block plugin <= 1.1.9 - Cross Site Scripting (XSS) vulnerability
- Severity: medium (CVSS 5.4 v3.1)
- Exploited in the wild: not listed in CISA KEV
- EPSS: 0.2% probability of exploitation in the next 30 days
- Public exploit or detection template: none known
- Published: 2025-01-09 · updated 2026-06-17
- Weakness: CWE-79
Description
Improper Neutralization of Input During Web Page Generation ('Cross-site Scripting') vulnerability in bPlugins Button Block button-block allows Stored XSS.This issue affects Button Block: from n/a through <= 1.1.9.
Affected products
- bPlugins Button Block: before 1.1.7 — fixed in 1.1.7
How to fix
Upgrade to a fixed version: bPlugins Button Block 1.1.7. Check the vendor advisory for mitigations.
References
Get alerted when CVE-2025-22815 or the next vulnerability affects your stack