What’s Vulnerable › Vulnerabilities
CVE-2025-22874: Usage of ExtKeyUsageAny disables policy validation in crypto/x509
- Severity: high (CVSS 7.5 v3.1)
- Exploited in the wild: not listed in CISA KEV
- EPSS: 0.4% probability of exploitation in the next 30 days
- Public exploit or detection template: none known
- Published: 2025-06-11 · updated 2026-06-17
Description
Calling Verify with a VerifyOptions.KeyUsages that contains ExtKeyUsageAny unintentionally disabledpolicy validation. This only affected certificate chains which contain policy graphs, which are rather uncommon.
Affected products
- Go standard library crypto/x509: from 1.24.0-0 before 1.24.4 — fixed in 1.24.4
How to fix
Upgrade to a fixed version: Go standard library crypto/x509 1.24.4. Check the vendor advisory for mitigations.
References
- https://go.dev/cl/670375
- https://go.dev/issue/73612
- https://groups.google.com/g/golang-announce/c/ufZ8WpEsA3A
- https://pkg.go.dev/vuln/GO-2025-3749
Get alerted when CVE-2025-22874 or the next vulnerability affects your stack