What’s Vulnerable › Vulnerabilities
CVE-2025-22891: BIG-IP PEM Vulnerability
- Severity: high (CVSS 7.5 v3.1)
- Exploited in the wild: not listed in CISA KEV
- EPSS: 0.4% probability of exploitation in the next 30 days
- Public exploit or detection template: none known
- Published: 2025-02-05 · updated 2026-06-17
- Weakness: CWE-772
Description
When BIG-IP PEM Control Plane listener Virtual Server is configured with Diameter Endpoint profile, undisclosed traffic can cause the Virtual Server to stop processing new client connections and an increase in memory resource utilization. Note: Software versions which have reached End of Technical Support (EoTS) are not evaluated.
Affected products
- F5 Networks, Inc. BIG-IP (PEM): from 15.1.0 before 15.1.10.6.0.11.6; from 16.1.0 before 16.1.5; from 17.1.0 before 17.1.2 — fixed in 15.1.10.6.0.11.6, 16.1.5, 17.1.2
How to fix
Upgrade to a fixed version: F5 Networks, Inc. BIG-IP (PEM) 15.1.10.6.0.11.6, 16.1.5, 17.1.2. Check the vendor advisory for mitigations.
References
Get alerted when CVE-2025-22891 or the next vulnerability affects your stack