What’s Vulnerable › Vulnerabilities
CVE-2025-2299: LuckyWP Table of Contents <= 2.1.10 - Cross-Site Request Forgery to Reflected Cross-Site Scripting
- Severity: medium (CVSS 6.1 v3.1)
- Exploited in the wild: not listed in CISA KEV
- EPSS: 0.2% probability of exploitation in the next 30 days
- Public exploit or detection template: none known
- Published: 2025-04-03 · updated 2026-06-17
- Weakness: CWE-79
Description
The LuckyWP Table of Contents plugin for WordPress is vulnerable to Cross-Site Request Forgery in all versions up to, and including, 2.1.10. This is due to missing or incorrect nonce validation on the 'ajaxEdit' function. This makes it possible for unauthenticated attackers to inject arbitrary web scripts via a forged request granted they can trick a site administrator into performing an action such as clicking on a link.
Affected products
- theluckywp LuckyWP Table of Contents: before 2.1.11 — fixed in 2.1.11
How to fix
Upgrade to a fixed version: theluckywp LuckyWP Table of Contents 2.1.11. Check the vendor advisory for mitigations.
References
- https://plugins.trac.wordpress.org/browser/luckywp-table-of-contents/trunk/admin/controllers/EditorBlockController.php#L30
- https://plugins.trac.wordpress.org/browser/luckywp-table-of-contents/trunk/admin/widgets/customizeSuccess/views/widget.php#L12
- https://plugins.trac.wordpress.org/changeset/3265169/
- https://www.wordfence.com/threat-intel/vulnerabilities/id/82df5b2e-4c4a-402f-99c9-694fa710009b?source=cve
Get alerted when CVE-2025-2299 or the next vulnerability affects your stack