What’s Vulnerable › Vulnerabilities
CVE-2025-23015: Apache Cassandra: User with MODIFY permission on ALL KEYSPACES can escalate privileges to superuser via unsafe actions
- Severity: high (CVSS 8.8 v3.1)
- Exploited in the wild: not listed in CISA KEV
- EPSS: 1.0% probability of exploitation in the next 30 days
- Public exploit or detection template: none known
- Published: 2025-02-04 · updated 2026-06-17
- Weakness: CWE-267
Description
Privilege Defined With Unsafe Actions vulnerability in Apache Cassandra. An user with MODIFY permission ON ALL KEYSPACES can escalate privileges to superuser within a targeted Cassandra cluster via unsafe actions to a system resource. Operators granting data MODIFY permission on all keyspaces on affected versions should review data access rules for potential breaches. This issue affects Apache Cassandra through 3.0.30, 3.11.17, 4.0.15, 4.1.7, 5.0.2. Users are recommended to upgrade to versions 3.0.31, 3.11.18, 4.0.16, 4.1.8, 5.0.3, which fixes the issue.
Affected products
- Apache Software Foundation Apache Cassandra: from 3.0.0 before 3.0.31; from 3.1 before 3.11.18; from 4.0.0 before 4.0.16; from 4.1.0 before 4.1.8; from 5.0.0 before 5.0.3 — fixed in 3.0.31, 3.11.18, 4.0.16, 4.1.8, 5.0.3
How to fix
Upgrade to a fixed version: Apache Software Foundation Apache Cassandra 3.0.31, 3.11.18, 4.0.16, 4.1.8. Check the vendor advisory for mitigations.
References
- https://lists.apache.org/thread/jmks4msbgkl65ssg69x728sv1m0hwz3s
- http://www.openwall.com/lists/oss-security/2025/02/03/2
- http://www.openwall.com/lists/oss-security/2025/02/11/1
- https://security.netapp.com/advisory/ntap-20250214-0006/
Get alerted when CVE-2025-23015 or the next vulnerability affects your stack