What’s Vulnerable › Vulnerabilities
CVE-2025-23047: Cilium vulnerable to information leakage via insecure default Hubble UI CORS header
- Severity: medium (CVSS 6.5 v3.1)
- Exploited in the wild: not listed in CISA KEV
- EPSS: 0.5% probability of exploitation in the next 30 days
- Public exploit or detection template: none known
- Published: 2025-01-22 · updated 2026-06-17
- Weakness: CWE-200
Description
Cilium is a networking, observability, and security solution with an eBPF-based dataplane. An insecure default `Access-Control-Allow-Origin` header value could lead to sensitive data exposure for users of Cilium versions 1.14.0 through 1.14.7, 1.15.0 through 1.15.11, and 1.16.0 through 1.16.4 who deploy Hubble UI using either Cilium CLI or via the Cilium Helm chart. A user with access to a Hubble UI instance affected by this issue could leak configuration details about the Kubernetes cluster which Hubble UI is monitoring, including node names, IP addresses, and other metadata about workloads and the cluster networking configuration. In order for this vulnerability to be exploited, a victim would have to first visit a malicious page. This issue is fixed in Cilium v1.14.18, v1.15.12, and v1.16.5. As a workaround, users who deploy Hubble UI using the Cilium Helm chart directly can remove the CORS headers from the Helm template as shown in the patch from commit a3489f190ba6e87b5336ee685fb6c80b1270d06d.
Affected products
- cilium: from 1.14.0 before 1.14.19; from 1.15.0 before 1.15.13; from 1.16.0 before 1.16.6 — fixed in 1.14.19, 1.15.13, 1.16.6
How to fix
Upgrade to a fixed version: cilium 1.14.19, 1.15.13, 1.16.6. Check the vendor advisory for mitigations.
References
- https://github.com/cilium/cilium/commit/a3489f190ba6e87b5336ee685fb6c80b1270d06d
- https://github.com/cilium/cilium/security/advisories/GHSA-h78m-j95m-5356
Get alerted when CVE-2025-23047 or the next vulnerability affects your stack