What’s Vulnerable › Vulnerabilities
CVE-2025-23048: Apache HTTP Server: mod_ssl access control bypass with session resumption
- Severity: critical (CVSS 9.1 v3.1)
- Exploited in the wild: not listed in CISA KEV
- EPSS: 1.0% probability of exploitation in the next 30 days
- Public exploit or detection template: none known
- Published: 2025-07-10 · updated 2026-06-17
- Weakness: CWE-284
Description
In some mod_ssl configurations on Apache HTTP Server 2.4.35 through to 2.4.63, an access control bypass by trusted clients is possible using TLS 1.3 session resumption. Configurations are affected when mod_ssl is configured for multiple virtual hosts, with each restricted to a different set of trusted client certificates (for example with a different SSLCACertificateFile/Path setting). In such a case, a client trusted to access one virtual host may be able to access another virtual host, if SSLStrictSNIVHostCheck is not enabled in either virtual host.
Affected products
- Apache HTTP Server: from 2.4.35 before 2.4.64 — fixed in 2.4.64
How to fix
Upgrade to a fixed version: Apache HTTP Server 2.4.64. Check the vendor advisory for mitigations.
References
- https://httpd.apache.org/security/vulnerabilities_24.html
- http://www.openwall.com/lists/oss-security/2025/07/10/2
- http://www.openwall.com/lists/oss-security/2025/07/10/8
- https://lists.debian.org/debian-lts-announce/2025/08/msg00009.html
Get alerted when CVE-2025-23048 or the next vulnerability affects your stack