What’s Vulnerable › Vulnerabilities
CVE-2025-23056: Authenticated Stored Cross-Site Scripting (XSS) Vulnerability in HPE Aruba Networking Fabric Composer Web Management Interface
- Severity: medium (CVSS 5.4 v3.1)
- Exploited in the wild: not listed in CISA KEV
- EPSS: 0.3% probability of exploitation in the next 30 days
- Public exploit or detection template: none known
- Published: 2025-01-28 · updated 2026-06-17
- Weakness: CWE-79
Description
A vulnerability in the web management interface of HPE Aruba Networking Fabric Composer could allow an authenticated remote attacker to conduct a stored cross-site scripting (XSS) attack. If successfully exploited, a threat actor could run arbitrary script code in a victim's web browser within the context of the compromised interface.
Affected products
- Hewlett Packard Enterprise (HPE) Fabric Composer: from 7.0.0 before 7.1.1 — fixed in 7.1.1
How to fix
Upgrade to a fixed version: Hewlett Packard Enterprise (HPE) Fabric Composer 7.1.1. Check the vendor advisory for mitigations.
References
Get alerted when CVE-2025-23056 or the next vulnerability affects your stack