What’s Vulnerable › Vulnerabilities

CVE-2025-23061

Description

Mongoose before 8.9.5 can improperly use a nested $where filter with a populate() match, leading to search injection. NOTE: this issue exists because of an incomplete fix for CVE-2024-53900.

Affected products

How to fix

Upgrade to a fixed version: automattic/mongoose 6.13.6, 7.8.4, 8.9.5. Check the vendor advisory for mitigations.

References

Get alerted when CVE-2025-23061 or the next vulnerability affects your stack