What’s Vulnerable › Vulnerabilities
CVE-2025-23078: XSS in BreadCrumbs2
- Severity: medium (CVSS 6.5 v3.1)
- Exploited in the wild: not listed in CISA KEV
- EPSS: 0.3% probability of exploitation in the next 30 days
- Public exploit or detection template: none known
- Published: 2025-01-10 · updated 2026-06-17
- Weakness: CWE-79
Description
Improper Neutralization of Input During Web Page Generation (XSS or 'Cross-site Scripting') vulnerability in Wikimedia Foundation Mediawiki - Breadcrumbs2 extension allows Cross-Site Scripting (XSS).This issue affects Mediawiki - Breadcrumbs2 extension: from 1.39.X before 1.39.11, from 1.41.X before 1.41.5, from 1.42.X before 1.42.4.
Affected products
- Wikimedia Foundation Mediawiki - Breadcrumbs2 extension: from 1.39.x before 1.39.11; from 1.41.x before 1.41.5; from 1.42.x before 1.42.4 — fixed in 1.39.11, 1.41.5, 1.42.4
How to fix
Upgrade to a fixed version: Wikimedia Foundation Mediawiki - Breadcrumbs2 extension 1.39.11, 1.41.5, 1.42.4. Check the vendor advisory for mitigations.
References
- https://gerrit.wikimedia.org/r/q/I7878f8f7bc067080f80427b90f8d85337f172711
- https://phabricator.wikimedia.org/T382043
Get alerted when CVE-2025-23078 or the next vulnerability affects your stack