What’s Vulnerable › Vulnerabilities
CVE-2025-23080: XSSes in Special:BadgeView
- Severity: medium (CVSS 5.3 v3.1)
- Exploited in the wild: not listed in CISA KEV
- EPSS: 0.3% probability of exploitation in the next 30 days
- Public exploit or detection template: none known
- Published: 2025-01-14 · updated 2026-06-17
- Weakness: CWE-79
Description
Improper Neutralization of Input During Web Page Generation (XSS or 'Cross-site Scripting') vulnerability in Wikimedia Foundation Mediawiki - OpenBadges Extension allows Cross-Site Scripting (XSS).This issue affects Mediawiki - OpenBadges Extension: from 1.39.X before 1.39.11, from 1.41.X before 1.41.3, from 1.42.X before 1.42.2.
Affected products
- Wikimedia Foundation Mediawiki - OpenBadges Extension: from 1.39.x before 1.39.11; from 1.41.x before 1.41.3; from 1.42.x before 1.42.2 — fixed in 1.39.11, 1.41.3, 1.42.2
How to fix
Upgrade to a fixed version: Wikimedia Foundation Mediawiki - OpenBadges Extension 1.39.11, 1.41.3, 1.42.2. Check the vendor advisory for mitigations.
References
- https://gerrit.wikimedia.org/r/q/Ic9448312fa7f1cbc8feac3f852bc8720568522e2
- https://phabricator.wikimedia.org/T381220
Get alerted when CVE-2025-23080 or the next vulnerability affects your stack