What’s Vulnerable › Vulnerabilities
CVE-2025-23081: Various security vulnerabilities in Extension:DataTransfer
- Severity: medium (CVSS 6.1 v3.1)
- Exploited in the wild: not listed in CISA KEV
- EPSS: 0.2% probability of exploitation in the next 30 days
- Public exploit or detection template: none known
- Published: 2025-01-14 · updated 2026-06-17
- Weakness: CWE-79
Description
Cross-Site Request Forgery (CSRF), Improper Neutralization of Input During Web Page Generation (XSS or 'Cross-site Scripting') vulnerability in Wikimedia Foundation Mediawiki - DataTransfer Extension allows Cross Site Request Forgery, Cross-Site Scripting (XSS).This issue affects Mediawiki - DataTransfer Extension: from 1.39.X before 1.39.11, from 1.41.X before 1.41.3, from 1.42.X before 1.42.2.
Affected products
- Wikimedia Foundation Mediawiki - DataTransfer Extension: from 1.39.x before 1.39.11; from 1.41.x before 1.41.3; from 1.42.x before 1.42.2 — fixed in 1.39.11, 1.41.3, 1.42.2
How to fix
Upgrade to a fixed version: Wikimedia Foundation Mediawiki - DataTransfer Extension 1.39.11, 1.41.3, 1.42.2. Check the vendor advisory for mitigations.
References
- https://gerrit.wikimedia.org/r/c/mediawiki/extensions/DataTransfer/+/1080451
- https://gerrit.wikimedia.org/r/c/mediawiki/extensions/DataTransfer/+/1093931
- https://gerrit.wikimedia.org/r/q/I5e1538a3bf66378810f905834c05626e1d2c82f0
- https://gerrit.wikimedia.org/r/q/I773c616db781d2f3f30893ad01ef503bf251a2b3
- https://gerrit.wikimedia.org/r/q/I7c9de4c8dcdb3276ba923c6bc7c8eef3531324c7
- https://gerrit.wikimedia.org/r/q/I9223c31f02f31f1e06e1a8cddf7d539cc8d3a3d9
- https://phabricator.wikimedia.org/T379749
Get alerted when CVE-2025-23081 or the next vulnerability affects your stack