What’s Vulnerable › Vulnerabilities
CVE-2025-23138: watch_queue: fix pipe accounting mismatch
- Severity: medium (CVSS 5.5 v3.1)
- Exploited in the wild: not listed in CISA KEV
- EPSS: 0.2% probability of exploitation in the next 30 days
- Public exploit or detection template: none known
- Published: 2025-04-16 · updated 2026-06-17
Description
In the Linux kernel, the following vulnerability has been resolved: watch_queue: fix pipe accounting mismatch Currently, watch_queue_set_size() modifies the pipe buffers charged to user->pipe_bufs without updating the pipe->nr_accounted on the pipe itself, due to the if (!pipe_has_watch_queue()) test in pipe_resize_ring(). This means that when the pipe is ultimately freed, we decrement user->pipe_bufs by something other than what than we had charged to it, potentially leading to an underflow. This in turn can cause subsequent too_many_pipe_buffers_soft() tests to fail with -EPERM. To remedy this, explicitly account for the pipe usage in watch_queue_set_size() to match the number set via account_pipe_buffers() (It's unclear why watch_queue_set_size() does not update nr_accounted; it may be due to intentional overprovisioning in watch_queue_set_size()?)
Affected products
- Debian Linux: 11.0
- Linux kernel: from 5.10.210 before 5.10.236; from 5.15.149 before 5.15.180; from 6.1.76 before 6.1.134; from 6.6.15 before 6.6.87; from 6.7.3 before 6.12.23; from 6.13 before 6.13.11 — fixed in 5.10.236, 5.15.180, 6.1.134, 6.12.23, 6.13.11, 6.14.2
How to fix
Upgrade to a fixed version: Linux kernel 5.10.236, 5.15.180, 6.1.134, 6.12.23. Check the vendor advisory for mitigations.
References
- https://git.kernel.org/stable/c/205028ebba838938d3b264dda1d0708fa7fe1ade
- https://git.kernel.org/stable/c/2d680b988656bb556c863d8b46d9b9096842bf3d
- https://git.kernel.org/stable/c/471c89b7d4f58bd6082f7c1fe14d4ca15c7f1284
- https://git.kernel.org/stable/c/56ec918e6c86c1536870e4373e91eddd0c44245f
- https://git.kernel.org/stable/c/6dafa27764183738dc5368b669b71e3d0d154f12
- https://git.kernel.org/stable/c/8658c75343ed00e5e154ebbe24335f51ba8db547
- https://git.kernel.org/stable/c/d40e3537265dea9e3c33021874437ff26dc18787
- https://git.kernel.org/stable/c/f13abc1e8e1a3b7455511c4e122750127f6bc9b0
- https://lists.debian.org/debian-lts-announce/2025/05/msg00030.html
- https://lists.debian.org/debian-lts-announce/2025/05/msg00045.html
Get alerted when CVE-2025-23138 or the next vulnerability affects your stack