What’s Vulnerable › Vulnerabilities
CVE-2025-2314: User Profile Builder – Beautiful User Registration Forms, User Profiles & User Role Editor <= 3.13.5 - Authenticated (Contributor+) Stored Cross-Site Scripting via Shortcode
- Severity: medium (CVSS 6.4 v3.1)
- Exploited in the wild: not listed in CISA KEV
- EPSS: 0.3% probability of exploitation in the next 30 days
- Public exploit or detection template: none known
- Published: 2025-04-16 · updated 2026-06-17
- Weakness: CWE-79
Description
The User Profile Builder – Beautiful User Registration Forms, User Profiles & User Role Editor plugin for WordPress is vulnerable to Stored Cross-Site Scripting via the plugin's shortcodes in all versions up to, and including, 3.13.5 due to insufficient input sanitization and output escaping on user supplied attributes. This makes it possible for authenticated attackers, with contributor-level access and above, to inject arbitrary web scripts in pages that will execute whenever a user accesses an injected page. The issue was partially patched in version 3.13.6 of the plugin, and fully patched in 3.13.7.
Affected products
- cozmoslabs User Profile Builder – Beautiful User Registration Forms, User Profiles & User Role Editor: through 3.13.6
References
- https://plugins.trac.wordpress.org/browser/profile-builder/tags/3.13.4/front-end/logout.php#L9
- https://plugins.trac.wordpress.org/changeset/3268402/
- https://www.wordfence.com/threat-intel/vulnerabilities/id/9ccf2b56-0355-43e6-a616-d06196e90972?source=cve
Get alerted when CVE-2025-2314 or the next vulnerability affects your stack