What’s Vulnerable › Vulnerabilities
CVE-2025-23140: misc: pci_endpoint_test: Avoid issue of interrupts remaining after request_irq error
- Severity: medium (CVSS 5.5 v3.1)
- Exploited in the wild: not listed in CISA KEV
- EPSS: 0.2% probability of exploitation in the next 30 days
- Public exploit or detection template: none known
- Published: 2025-05-01 · updated 2026-06-17
Description
In the Linux kernel, the following vulnerability has been resolved: misc: pci_endpoint_test: Avoid issue of interrupts remaining after request_irq error After devm_request_irq() fails with error in pci_endpoint_test_request_irq(), the pci_endpoint_test_free_irq_vectors() is called assuming that all IRQs have been released. However, some requested IRQs remain unreleased, so there are still /proc/irq/* entries remaining, and this results in WARN() with the following message: remove_proc_entry: removing non-empty directory 'irq/30', leaking at least 'pci-endpoint-test.0' WARNING: CPU: 0 PID: 202 at fs/proc/generic.c:719 remove_proc_entry +0x190/0x19c To solve this issue, set the number of remaining IRQs to test->num_irqs, and release IRQs in advance by calling pci_endpoint_test_release_irq(). [kwilczynski: commit log]
Affected products
- Debian Linux: 11.0
- Linux kernel: from 4.19 before 5.4.293; from 5.5 before 5.10.237; from 5.11 before 5.15.181; from 5.16 before 6.1.135; from 6.2 before 6.6.88; from 6.7 before 6.12.25 — fixed in 5.10.237, 5.15.181, 5.4.293, 6.1.135, 6.12.25, 6.14.3
How to fix
Upgrade to a fixed version: Linux kernel 5.10.237, 5.15.181, 5.4.293, 6.1.135. Check the vendor advisory for mitigations.
References
- https://git.kernel.org/stable/c/0557e70e2aeba8647bf5a950820b67cfb86533db
- https://git.kernel.org/stable/c/54c9f299ad7d7c4be5d271ed12d01a59e95b8907
- https://git.kernel.org/stable/c/5a4b7181213268c9b07bef8800905528435db44a
- https://git.kernel.org/stable/c/705be96504779e4a333ea042b4779ea941f0ace9
- https://git.kernel.org/stable/c/770407f6173f4f39f4e2c1b54422b79ce6c98bdb
- https://git.kernel.org/stable/c/9d5118b107b1a2353ed0dff24404aee2e6b7ca0a
- https://git.kernel.org/stable/c/e516e187bf32d8decc7c7d0025ae4857cad13c0e
- https://git.kernel.org/stable/c/f6cb7828c8e17520d4f5afb416515d3fae1af9a9
- https://lists.debian.org/debian-lts-announce/2025/05/msg00030.html
- https://lists.debian.org/debian-lts-announce/2025/05/msg00045.html
Get alerted when CVE-2025-23140 or the next vulnerability affects your stack