What’s Vulnerable › Vulnerabilities
CVE-2025-23156: media: venus: hfi_parser: refactor hfi packet parsing logic
- Severity: high (CVSS 7.1 v3.1)
- Exploited in the wild: not listed in CISA KEV
- EPSS: 0.2% probability of exploitation in the next 30 days
- Public exploit or detection template: none known
- Published: 2025-05-01 · updated 2026-07-30
- Weakness: CWE-125
Description
In the Linux kernel, the following vulnerability has been resolved: media: venus: hfi_parser: refactor hfi packet parsing logic words_count denotes the number of words in total payload, while data points to payload of various property within it. When words_count reaches last word, data can access memory beyond the total payload. This can lead to OOB access. With this patch, the utility api for handling individual properties now returns the size of data consumed. Accordingly remaining bytes are calculated before parsing the payload, thereby eliminates the OOB access possibilities.
Affected products
- Debian Linux: 11.0
- Linux kernel: from 4.19 before 5.10.237; from 5.11 before 5.15.181; from 5.16 before 6.1.135; from 6.2 before 6.6.88; from 6.7 before 6.12.24; from 6.13 before 6.13.12 — fixed in 5.10.237, 5.15.181, 6.1.135, 6.12.24, 6.13.12, 6.14.3
How to fix
Upgrade to a fixed version: Linux kernel 5.10.237, 5.15.181, 6.1.135, 6.12.24. Check the vendor advisory for mitigations.
References
- https://git.kernel.org/stable/c/05b07e52a0d08239147ba3460045855f4fb398de
- https://git.kernel.org/stable/c/0beabe9b49190a02321b02792b29fc0f0e28b51f
- https://git.kernel.org/stable/c/0f9a4bab7d83738963365372e4745854938eab2d
- https://git.kernel.org/stable/c/6d278c5548d840c4d85d445347b2a5c31b2ab3a0
- https://git.kernel.org/stable/c/9edaaa8e3e15aab1ca413ab50556de1975bcb329
- https://git.kernel.org/stable/c/a736c72d476d1c7ca7be5018f2614ee61168ad01
- https://git.kernel.org/stable/c/bb3fd8b7906a12dc2b61389abb742bf6542d97fb
- https://git.kernel.org/stable/c/f195e94c7af921d99abd79f57026a218d191d2c7
- https://lists.debian.org/debian-lts-announce/2025/05/msg00030.html
- https://lists.debian.org/debian-lts-announce/2025/05/msg00045.html
Get alerted when CVE-2025-23156 or the next vulnerability affects your stack