What’s Vulnerable › Vulnerabilities
CVE-2025-23161: PCI: vmd: Make vmd_dev::cfg_lock a raw_spinlock_t type
- Severity: medium (CVSS 5.5 v3.1)
- Exploited in the wild: not listed in CISA KEV
- EPSS: 0.1% probability of exploitation in the next 30 days
- Public exploit or detection template: none known
- Published: 2025-05-01 · updated 2026-06-17
- Weakness: CWE-667
Description
In the Linux kernel, the following vulnerability has been resolved: PCI: vmd: Make vmd_dev::cfg_lock a raw_spinlock_t type The access to the PCI config space via pci_ops::read and pci_ops::write is a low-level hardware access. The functions can be accessed with disabled interrupts even on PREEMPT_RT. The pci_lock is a raw_spinlock_t for this purpose. A spinlock_t becomes a sleeping lock on PREEMPT_RT, so it cannot be acquired with disabled interrupts. The vmd_dev::cfg_lock is accessed in the same context as the pci_lock. Make vmd_dev::cfg_lock a raw_spinlock_t type so it can be used with interrupts disabled. This was reported as: BUG: sleeping function called from invalid context at kernel/locking/spinlock_rt.c:48 Call Trace: rt_spin_lock+0x4e/0x130 vmd_pci_read+0x8d/0x100 [vmd] pci_user_read_config_byte+0x6f/0xe0 pci_read_config+0xfe/0x290 sysfs_kf_bin_read+0x68/0x90 [bigeasy: reword commit message] Tested-off-by: Luis Claudio R. Goncalves <lgoncalv@redhat.com> [kwilczynski: commit log] [bhelgaas: add back report info from https://lore.kernel.org/lkml/20241218115951.83062-1-ryotkkr98@gmail.com/]
Affected products
- Debian Linux: 11.0
- Linux kernel: before 5.15.181; from 5.16 before 6.1.135; from 6.2 before 6.6.88; from 6.7 before 6.12.24; from 6.13 before 6.13.12; from 6.14 before 6.14.3 — fixed in 5.15.181, 6.1.135, 6.12.24, 6.13.12, 6.14.3, 6.6.88
How to fix
Upgrade to a fixed version: Linux kernel 5.15.181, 6.1.135, 6.12.24, 6.13.12. Check the vendor advisory for mitigations.
References
- https://git.kernel.org/stable/c/13e5148f70e81991acbe0bab5b1b50ba699116e7
- https://git.kernel.org/stable/c/18056a48669a040bef491e63b25896561ee14d90
- https://git.kernel.org/stable/c/20d0a9062c031068fa39f725a32f182b709b5525
- https://git.kernel.org/stable/c/2358046ead696ca5c7c628d6c0e2c6792619a3e5
- https://git.kernel.org/stable/c/5c3cfcf0b4bf43530788b08a8eaf7896ec567484
- https://git.kernel.org/stable/c/c250262d6485ca333e9821f85b07eb383ec546b1
- https://git.kernel.org/stable/c/c2968c812339593ac6e2bdd5cc3adabe3f05fa53
- https://lists.debian.org/debian-lts-announce/2025/05/msg00045.html
Get alerted when CVE-2025-23161 or the next vulnerability affects your stack