What’s Vulnerable › Vulnerabilities
CVE-2025-23196: Apache Ambari: Code Injection Vulnerability in Ambari Alert Definition
- Severity: high (CVSS 8.8 v3.1)
- Exploited in the wild: not listed in CISA KEV
- EPSS: 1.3% probability of exploitation in the next 30 days
- Public exploit or detection template: none known
- Published: 2025-01-21 · updated 2026-06-17
- Weakness: CWE-77
Description
A code injection vulnerability exists in the Ambari Alert Definition feature, allowing authenticated users to inject and execute arbitrary shell commands. The vulnerability arises when defining alert scripts, where the script filename field is executed using `sh -c`. An attacker with authenticated access can exploit this vulnerability to inject malicious commands, leading to remote code execution on the server. The issue has been fixed in the latest versions of Ambari.
Affected products
- Apache Software Foundation Apache Ambari: before 2.7.9 — fixed in 2.7.9
How to fix
Upgrade to a fixed version: Apache Software Foundation Apache Ambari 2.7.9. Check the vendor advisory for mitigations.
References
- https://lists.apache.org/thread/70g1l5lxvko7kvhyxmtmklhhfrlon837
- http://www.openwall.com/lists/oss-security/2025/01/21/8
Get alerted when CVE-2025-23196 or the next vulnerability affects your stack