What’s Vulnerable › Vulnerabilities
CVE-2025-23198: Stored-XSS-LibreNMS-Display-Name in librenms
- Severity: medium (CVSS 5.4 v3.1)
- Exploited in the wild: not listed in CISA KEV
- EPSS: 0.4% probability of exploitation in the next 30 days
- Public exploit or detection template: yes
- Published: 2025-01-16 · updated 2026-06-17
- Weakness: CWE-79
Description
librenms is a community-based GPL-licensed network monitoring system. Affected versions are subject to a stored XSS on the parameters (Replace $DEVICE_ID with your specific $DEVICE_ID value):`/device/$DEVICE_ID/edit` -> param: display. Librenms versions up to 24.10.1 allow remote attackers to inject malicious scripts. When a user views or interacts with the page displaying the data, the malicious script executes immediately, leading to potential unauthorized actions or data exposure. This issue has been addressed in release version 24.11.0. Users are advised to upgrade. There are no known workarounds for this vulnerability.
Affected products
- librenms: before 24.11.0 — fixed in 24.11.0
How to fix
Upgrade to a fixed version: librenms 24.11.0. Check the vendor advisory for mitigations.
References
Get alerted when CVE-2025-23198 or the next vulnerability affects your stack